返回常见问题列表 安装弹出提示框《此安装程序需要 .Net Framework 版本 x.x。请安装该 .Net Framework 版本,然后重新运行该安装程序。》

搜索易是基于.Net开发的应用,如果您在安装搜索易之前尚未安装.Net,则会弹出这个提示框.

什么是microsoft .net framework

Microsoft .NET Framework是由微软公司开发,是用于Windows的新托管代码编程模型。它强大功能与新技术结合起来,用于构建具有视觉上引人注目的用户体验的应用程序,实现跨技术边界的无缝通信,并且能支持各种业务流程。 详情:百度百科

----------------------------------------------

windows 8操作系统默认自带.Net4.0
windows 7操作系统默认自带.Net3.5
windows vista操作系统默认自带.Net3.0
windows xp,windows 2003及更低版本操作系统默认不含.Net任何版本,需用户自行安装.

如何查看我是否安装了.NET环境,以及相应的版本关闭悬浮窗,查看其他信息

在已安装的程序列表中查找

开始菜单 » 控制面板 » 程序和功能(添加或删除程序) 中查找 microsoft .net framework 开头的名称,后面跟着的就是版本号.

页面智能检测

.NET各版本的差异:

.Net3.5是.Net3.0的升级版,.Net3.0是.Net2.0的升级版,他们的内核均为.Net2.0;

.Net4.0是微软重新设计的版本,他不基于.Net2.0;

.Net4.5是.Net4.0的升级版,他的内核为.Net4.0

基于Net2.0的搜索易和基于Net4.0的搜索易他们有什么区别?

他们没有功能区别,选择您已安装的Net环境下载对应的搜索易安装包即可.

系统要求

详细描述.Net2.0 SP2

支持的操作系统:Windows Server 2003, Windows XP
  • • Windows Installer:Windows Installer 3.1 或更高版本(推荐)
  • • Internet Explorer:如果使用 Internet Explorer,则需要 Internet Explorer 6.0 或更高版本
  • • 软件:在 Windows Server 2000 SP4 上,在安装 .NET Framework 2.0 Service Pack 2 之前,安装 KB 835732。
  • • 处理器:400 MHz Pentium 处理器或与之相当的处理器(最低);1GHz Pentium 处理器或与之相当的处理器(推荐)
  • • RAM:96 MB(最低);256 MB(推荐)
  • • 硬盘:可能最多需要 500 MB 可用空间
  • • CD 或 DVD 驱动器:不需要
  • • 显示器:800 x 600,256 色(最低配置);1024 x 768 增强色,32 位(建议配置)

详细描述.Net3.0 SP1

支持的操作系统:Windows Server 2003, Windows XP
  • • 处理器:400 MHz Pentium 处理器或与之相当的处理器(最低配置);1GHz Pentium 处理器或与之相当的处理器(建议配置)
  • • RAM:96 MB(最低配置);256 MB(建议配置)
  • • 硬盘:最多可能需要 500 MB 的可用空间
  • • CD 或 DVD 驱动器:不需要
  • • 显示器:800 x 600,256 色(最低配置);1024 x 768 增强色,32 位(建议配置)

详细描述.Net3.5 SP1

支持的操作系统:Windows Server 2003, Windows Server 2008, Windows Vista, Windows XP
  • • 处理器:400 MHz Pentium 处理器或与之相当的处理器(最低);1 GHz Pentium 处理器或与之相当的处理器(推荐)
  • • RAM:96 MB(最低);256 MB(推荐)
  • • 硬盘:最多可能需要 500 MB 的可用空间
  • • CD 或 DVD 驱动器:不需要
  • • 显示器:800 x 600,256 色(最低);1024 x 768 增强色,32 位(推荐)

详细描述.Net4.0

支持的操作系统:Windows 7, Windows 7 Service Pack 1, Windows Server 2003 Service Pack 2, Windows Server 2008, Windows Server 2008 R2, Windows Server 2008 R2 SP1, Windows Vista Service Pack 1, Windows XP Service Pack 3
  • • Windows XP SP3
  • • Windows Server 2003 SP2
  • • Windows Vista SP1 或更高版本
  • • Windows Server 2008(在服务器核心角色上不受支持)
  • • Windows 7
  • • Windows Server 2008 R2(在服务器核心角色上不受支持)
  • • Windows 7 SP1
  • • Windows Server 2008 R2 SP1

支持的体系结构:
  • • x86
  • • x64
  • • ia64(有些功能在诸如 WPF 之类的 ia64 上不受支持)

硬件要求:
  • • 建议的最低要求:Pentium 1 GHz 或更快,512 MB RAM 或更大
  • • 最小磁盘空间:x86 – 850 MB
  • • 最小磁盘空间:x64 – 2 GB

详细描述.Net4.5

支持的操作系统:Windows 7 Service Pack 1, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Vista Service Pack 2
  • • Windows Vista SP2(x86 和 x64)
  • • Windows 7 SP1(x86 和 x64)
  • • Windows Server 2008 R2 SP1 (x64)
  • • Windows Server 2008 SP2(x86 和 x64)

硬件要求:
  • • 1 GHz 或更快的处理器
  • • 512 MB RAM
  • • 850 MB 的可用硬盘空间 (x86)
  • • 2 GB 硬盘 (x64)

.Net各版本下载